WordPress.org

Plugin Directory

geo

Opened 11 years ago

Last modified 11 years ago

#575 new defect

Geo Plugin - Fields in Post.php not showing up and blocking rest

Reported by: Merano Owned by: ringmaster
Priority: high Severity: major
Plugin: geo Keywords: php 5.2 ob_start
Cc:

Description

Hi, hope I am posting it right....

I have installed the newest Geo-plugin on a wp 2.0.7 and on a wp 2.1. installation.

Everything worked fine until my host changed from PHP 5.0 to PHP 5.2. Could this be the reason?

Now, the fields aren't showing up on the post.php anymore and I can't see anything below the place where the geo fields should be...

Can anyone help me with that?

Thanks a lot in advance

Attachments (1)

pic_02.jpg (9.1 KB) - added by Hardmood 11 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 @Hardmood11 years ago

Hi (hope I am posting it right aswell),

I have to report the same problem under WP 2.0.5

My Host (Host Europe; www.hosteurope.de) changed PHP 5.0 to PHP 5.2.

Deactivating the Geo-plugin brings the "advanced editing options" back (in the Administration > Options > Writing Sub-Panel) but shows a "Fatal error" (which comes from the geomashup-plugin) at the normal website:

-> Fatal error: Call to undefined function get_lat() on line 519

So, what to do next?

comment:2 @Merano11 years ago

Hi,

you probably get an error because the get_lat function is only available when the plugin is activated.

I've read something about date and timezone changes from PHP 5.0 to 5.2 and I thought that this could cause the troubles but I don't have enough experience to find the problem myself.

Can anyone help us?

@Hardmood11 years ago

comment:3 @Hardmood11 years ago

  • Keywords php 5.2 added

Hi,

So, ... I think we are not the only ones with such problems (http://wordpress.org/support/topic/92967). It comes together with PHP 5.2 and it could be a Wordpress bug (!? - but I am not a programmer and cannot say for sure). I asked my Hoster to change my account back to an earlier PHP Version but for security reasons they don't do that. After that I tried changing the status of the php-extensions:

PHP4 -> phtml php4 php3 php
PHP5 -> php5

Should have worked because WP uses PHP 4.2 or higher, but did not. (It brought the alarm shown on this screenshot: http://dev.wp-plugins.org/attachment/ticket/575/pic_02.jpg )

I talked aswell to Dylan (http://www.cyberhobo.net) who is the programmer of the geomashup-plugin. We (or better: he :-) ) are still searching for an answer.

By the way: The same problem was with the older geomashup-plugin version 0.5.

Has anybody got anymore ideas?

comment:4 @Merano11 years ago

Would be cool if Dylan could help us...

I somehow think it's just a problem of the geo plugin.... since all others work fine in my installation...

By the way...
I don't get your screenshot.... that's no error...that's just the source code what's inside the index.php file that's located in your wordpress installation... (??)

comment:5 @Hardmood11 years ago

(The screenshot just shows the code which was shown in my browser after changing the status of the php-extensions -> so nothing very important )

;-)

comment:6 @Merano11 years ago

  • Keywords ob_start added

I am not sure, but could it be possible that I found something?

In PHP 5.2.0 there was a bug with the ob_start function (see http://bugs.php.net/bug.php?id=40259) which was only fixed in 5.2.1 (see changelog: http://www.php.net/ChangeLog-5.php).

The ob_start function is being used in the plugin - could this cause the whole problem?

Is there a possibility to use another function instead?
(I don't think my host is gonna do another upgrade only 'cause I have this plugin not working....)

comment:7 follow-up: @Hardmood11 years ago

so, ... it is working again.

Dylan (http://www.cyberhobo.net) - the programmer of the geomashup plugin - was kind enough to help me out -> I still don't know what he did but when I find out I'll post it!

cheers, Felix.

comment:8 in reply to: ↑ 7 @Merano11 years ago

Mine is still not working :-(

Did he send you another geo.php file?
If so, could you post the source code?

So I could compare myself and see where there are changes....

Thanks a lot!
Cheers,
Merano

comment:9 @Hardmood11 years ago

He wrote me in the last mail: "I don't think what I did on your blog is the best solution. After some more research, I think I would tell people to try the latest version of cache.php from the WordPress source repository (http://trac.wordpress.org/browser/trunk/wp-includes/cache.php). I don't know if that will work, but there have been fixes to it.(...)" As a reminder: I gave him an admin-account on my blog so that he could test around. The geomashup-plugin-version on the server doesn't use the geo-plugin anymore. I put it into a .zip-file to download from: http://www.felix-beck.de/geo-mashup.zip

felix

Note: See TracTickets for help on using tickets.