WordPress.org

Plugin Directory

jetpack

Opened 4 years ago

Closed 4 years ago

#2089 closed defect (duplicate)

i18n: unify wrong textdomains beside "jetpack" to only use "jetpack"

Reported by: daveshine Owned by: tmoorewp
Priority: normal Severity: normal
Plugin: jetpack Keywords: i18n minileven
Cc: daveshine, jeremy+wp@…

Description

Currently, as of version 2.7 of Jetpack, there the following textdomains in use within the various parts/modules of the plugin:

  • 'jetpack' (default, majority of instances!)
  • 'minileven'
  • 'default' (not defined, strings are without textdomain and fallback to 'default')
  • 'nova'
  • plus 2 textdomain errors, caused by the reasons laid down in ticket #2087 (error domains are "share to" and "next-saturday"...)

All these textdomains should be unified to 'jetpack' alone!
'minileven' may be a bit of a mixed case but in reality it leads to non-displayed translations! The user has to declare manually a loading function for 'minileven'... I guess this is too unknown and complicated to most users so it should be unified to 'jetpack' also! Note: some textdomains within "Minileven" mobile theme module already use 'jetpack' textdomain! So please make it complete!

Change History (3)

comment:1 @daveshine4 years ago

Note: the reasons for the 2 errors are actually laid down in my reported ticket #2088, the above ticket number was wrong!

comment:2 @jeherve4 years ago

  • Cc jeremy+wp@… added
  • Keywords i18n minileven added
  • Summary changed from Unify wrong textdomains beside "jetpack" to only use "jetpack" to i18n: unify wrong textdomains beside "jetpack" to only use "jetpack"

comment:3 @jeherve4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Ported to GitHub here:

@daveshine I'll keep looking for strings without texdomain, and for strings using "minileven", but if you find some by myself do not hesitate to let me know here, or on GitHub.

Thanks!

Note: See TracTickets for help on using tickets.