Plugin Directory


Opened 4 years ago

Closed 4 years ago

#2063 closed defect (duplicate)

Widget visibility: is_active_sidebar always returns true

Reported by: mdjnewman Owned by: tmoorewp
Priority: normal Severity: normal
Plugin: jetpack Keywords: widget-visibility


When using "Widget Visibility", I'm having issues with is_active_sidebar always returning true, even if there are no visible widgets in the sidebar for a given page.

In my current theme, this results in blank space down the right hand side of the page.

Steps to reproduce (using Twenty Thirteen theme):

  1. Activate Jetpack and the Widget Visibility module
  2. Configure a single widget that is visible on only one page
  3. Go to any other page

I've had a look at the source, I'm guessing this kind of filtering should be done by the following line in wp_get_sidebars_widgets:

$sidebars_widgets = apply_filters('sidebars_widgets', $sidebars_widgets);

My PHP skills are pretty ordinary and I'm not overly familiar with WordPress, so I didn't dig much beyond finding the sidebars_widgets function in widget-conditions.php which looks like it should be doing this kind of filtering.

Has anyone else encountered this issue?

URL: http://mdjnewman.me/
WP version: 3.7.1
Jetpack version: 2.6
Theme: Twenty Thirteen, Version 1.1

Change History (1)

comment:1 @jeherve4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.