WordPress.org

Plugin Directory

jetpack

Opened 4 years ago

Closed 4 years ago

#2038 closed defect (duplicate)

Shortcodes: Soundcloud shortcode always uses HTTP, never HTTPS

Reported by: jeherve Owned by: tmoorewp
Priority: normal Severity: normal
Plugin: jetpack Keywords: shortcodes soundcloud
Cc: jeherve, richardmtl

Description

Steps to reproduce:

  1. On a site using only HTTPS, activate Jetpack and the Shortcodes module
  2. Embed a Soundcloud player in one of your posts, like so:
[soundcloud url="https://api.soundcloud.com/tracks/119453276" width="100%" height="166" iframe="true" /]
  1. Publish
  2. Open the post
    • You'll receive a mixed-content warning because the SoundCloud player is served via HTTP on a page using only HTTPS

Reported here:

Change History (1)

comment:1 @jeherve4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.