WordPress.org

Plugin Directory

jetpack

Opened 4 years ago

Closed 4 years ago

#2026 closed defect (duplicate)

Stats: Detailed post stats page is broken with WooCommerce Active

Reported by: bftrick Owned by: tmoorewp
Priority: normal Severity: normal
Plugin: jetpack Keywords: stats plugin-compat woocommerce
Cc: bftrick@…, blobaugh, jeremy+wp@…

Description

There seems to be an issue with the Jetpack Page Stats page breaking when WooCommerce is active.

Click on the blue arrow here: http://cld.wthms.co/h4X1

See this error: http://cld.wthms.co/H26r

It happens with the latest version of Jetpack & WooCommerce installed. If you disable WooCommerce the stats page works as per usual. Is this an error within Jetpack or WooCommerce. I'm not terribly familiar with the JP codebase but I would be more than happy to submit a patch if someone can point me in the right direction.

Attachments (2)

stats-page.png (127.1 KB) - added by bftrick 4 years ago.
stats page
error.png (22.0 KB) - added by bftrick 4 years ago.
the error that's displayed when WC & JP are active

Download all attachments as: .zip

Change History (9)

@bftrick4 years ago

stats page

@bftrick4 years ago

the error that's displayed when WC & JP are active

comment:1 @jfarsen4 years ago

I'm the end-user, adding a comment to be notified of any updates to this ticket. Tks!

comment:2 @bftrick4 years ago

I forgot to mention that this related to WooThemes support ticket 114901

Last edited 4 years ago by bftrick (previous) (diff)

comment:3 @blobaugh4 years ago

  • Cc blobaugh added

comment:4 @jeherve4 years ago

  • Cc jeremy+wp@… added
  • Keywords plugin-compat added
  • Summary changed from Jetpack Page Stats Page Broken with WooCommerce Active to Stats: Detailed post stats page is broken with WooCommerce Active

I can reproduce with the latest version of Jetpack and Woocommerce.

comment:5 @jfarsen4 years ago

Hi, wanted to confirm that WooCommerce 2.0.19 still causes the same problem. Disabling it re-enables access to individual stats.

comment:6 follow-up: @bftrick4 years ago

This error doesn't seem to appear in the source code for /jetpack/modules/stats.php at all. It looks like this might have been an error sent back from the remote request. Most likely from line 428 in /jetpack/modules/stats.php.

Can someone on the JetPack team give me an idea of what that error means?

Perhaps WC is somehow changing one of the parameters being sent out in the request?

comment:7 in reply to: ↑ 6 @jeherve4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.