WordPress.org

Plugin Directory

jetpack

Opened 4 years ago

Closed 4 years ago

#2006 closed defect (duplicate)

Unnecessary title attributes

Reported by: joshuagoodwin Owned by: tmoorewp
Priority: normal Severity: normal
Plugin: jetpack Keywords: sharedaddy
Cc: richard@…

Description

Many link title attributes have been removed from WordPress core in version 3.7 for reasons that I might as well just quote from the core ticket:

The title attribute provides a tooltip on certain browsers. Other than that, it is essentially useless. As provided in Wordpress, the title attribute is both redundant and useless, because in most cases, it is a complete duplicate of the link's text. Therefore the tooltip provided is of no value whatsoever.

For users of assistive technologies, the title attribute is useless at best and sometimes an annoyance. Users of text-to-speech software who have configured their software to do so will hear the title attribute twice.

Essentially the extensive use of title attributes throughout Wordpress Core amounts to unnecessary code bloat.

Jetpack is guilty of the same in some places, for example the Sharedaddy sharing links. This should be addressed.

Change History (2)

comment:1 @richardmtl4 years ago

  • Cc richard@… added

comment:2 @jeherve4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.