WordPress.org

Plugin Directory

jetpack

Opened 4 years ago

Closed 4 years ago

#1984 closed defect (duplicate)

Grunion: Activating jetpack in a subsite in a multisite setup deactivates Grunion if activated network-wide

Reported by: richardmtl Owned by: tmoorewp
Priority: normal Severity: normal
Plugin: jetpack Keywords: grunion
Cc:

Description

  1. Install Grunion and network activate
  2. Install Jetpack, do not network activate
  3. Go to a specific sub site and activate Jetpack
  4. Connect Jetpack with your WordPress.com account

Expected result: Grunion gets deactivated on that specific subsite only

Actual result: Grunion gets deactivated network-wide

This is undesirable because even though Grunion is no longer under development and is now folded into the Jetpack Contact Form module, we shouldn't deactivate it across the network unless Jetpack is also network-activated.

Note that this may only happen if Jetpack is activated and connected using a Super-Admin account, and not just a subsite admin account. Nonetheless it is unexpected behaviour.

Originally reported here: http://wordpress.org/support/topic/jet-pack-erroneously-deactivates-plugins-in-other-multi-site-sites?replies=5#post-4656771

Change History (1)

comment:1 @jeherve4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.