WordPress.org

Plugin Directory

jetpack

Opened 4 years ago

Closed 4 years ago

#1869 closed defect (duplicate)

Audio Shortcode: fallback to Jetpack's player for playlists

Reported by: jeherve Owned by: tmoorewp
Priority: normal Severity: major
Plugin: jetpack Keywords: shortcodes audio playlist
Cc: jeherve, richard@…

Description

Steps to reproduce:

  1. In WordPress 3.5.2, create a new post including the following shortcode:
    [audio http://www.mbird.com/wp-content/uploads/2011/11/01-Ive-Been-A-Bad-Bad-Boy.mp3, http://www.mbird.com/wp-content/uploads/2011/11/02-A-Breath-Taking-Guy.mp3, http://www.mbird.com/wp-content/uploads/2011/11/03-If-Dolphins-Were-Monkeys.mp3, http://www.mbird.com/wp-content/uploads/2011/11/04-I-Told-Her-on-Alderaan.mp3, http://www.mbird.com/wp-content/uploads/2011/11/05-Right-Behind-You.mp3, http://www.mbird.com/wp-content/uploads/2011/11/06-Speedway.mp3, http://www.mbird.com/wp-content/uploads/2011/11/07-Man-Sized-Wreath.mp3, http://www.mbird.com/wp-content/uploads/2011/11/08-Church-On-White.mp3, http://www.mbird.com/wp-content/uploads/2011/11/09-Its-Real.mp3, http://www.mbird.com/wp-content/uploads/2011/11/10-The-Reason.mp3, http://www.mbird.com/wp-content/uploads/2011/11/11-Theres-No-Way-Out-Of-Here.mp3, http://www.mbird.com/wp-content/uploads/2011/11/12-In-No-Resistance.mp3, http://www.mbird.com/wp-content/uploads/2011/11/13-Bad-Blood.mp3, http://www.mbird.com/wp-content/uploads/2011/11/14-The-Neighbor.mp3, http://www.mbird.com/wp-content/uploads/2011/11/15-The-Road-to-Birmingham.mp3, http://www.mbird.com/wp-content/uploads/2011/11/16-Boulder-to-Birmingham.mp3, http://www.mbird.com/wp-content/uploads/2011/11/17-In-The-World.mp3, http://www.mbird.com/wp-content/uploads/2011/11/18-Nothing-Lasts-Forever.mp3|titles=I've Been a Bad Bad Boy, A Breath Taking Guy, If Dolphins Were Monkeys, I Told Her on Alderaan, Right Behind You, Speedway, Man-Sized Wreath, Church on White, It's Real, The Reason, There's No Way Out of Here, In No Resistance, Bad Blood, The Neighbor, The Road to Birmingham, Boulder to Birmingham, In The World, Nothing Lasts Forever|artists=Paul Jones, The Marvelettes, Ian Brown, Neon Neon, Brandon Flowers, Morrissey, R.E.M., Stephen Malkmus, Real Estate, Thunderclap Newman, David Gilmour, Frankie Miller, Crooked Fingers, Dixie Chicks, Mott the Hoople, Emmylou Harris, Ryan Adams, Echo and the Bunnymen]
    
  2. Jetpack's player inserts a playlist in your post.
  3. Update to WP 3.6
    • Jetpack's audio player is deactivated, and since the core Audio shortcode doesn't support multiple audio files, the shortcode is displayed in the post as is.

Until Core support multiple audio files, it would be nice if Jetpack could detect shortcodes including multiple audio files, and use the Jetpack player.

Reported here:

Related: #1794

Change History (4)

comment:1 @jeherve4 years ago

  • Component changed from not-listed to jetpack
  • Owner set to tmoorewp

comment:2 @richardmtl4 years ago

  • Cc richard@… added

comment:4 @kraftbj4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.