WordPress.org

Plugin Directory

jetpack

Opened 2 years ago

Closed 13 months ago

#1809 closed defect (fixed)

Publicize: Facebook doesn't list Pages I manage anymore

Reported by: jeherve Owned by: tmoorewp
Priority: highest Severity: blocker
Plugin: jetpack Keywords: publicize facebook pages
Cc: jeherve, richard@…, jason@…

Description

Publicize to Facebook doesn't seem to show the available Pages to manage anymore:

http://i.wpne.ws/Q3oY/content

A notice also appears if WP_DEBUG is active:

Notice/home/wpnews/public_html/tagada/wp-content/plugins/jetpack/modules/publicize/publicize-jetpack.php346

http://plugins.trac.wordpress.org/browser/jetpack/tags/2.3.1/modules/publicize/publicize-jetpack.php#L346

Everything seems to be working properly on WordPress.com though.
Could the problem be linked to r723184, since it was the last change made to Jetpack Publicize to Facebook?

Change History (18)

comment:6 follow-ups: @jeherve2 years ago

  • Keywords needs-testing added

First pass at a fix: r739334, props tmoorewp

Publicize: remove the permission check from displaying Page accounts that could be used. Also, default Publicize checkboxes on published posts to unchecked so that there is no accidental Publicizing of said post.

comment:8 @richardmtl2 years ago

  • Cc richard@… added

comment:10 in reply to: ↑ 6 @supernovia2 years ago

Replying to jeherve:

First pass at a fix: r739334, props tmoorewp

I've tried this on my site and on clients' site (ref: 1594768). So far so good. :)

comment:11 in reply to: ↑ 6 ; follow-up: @nogi2 years ago

How do I apply the fix? Where can I grab the dependencies from as well as just the new php isn't enough. Sorry for the newbie question, I'm used to Google Code, Trac is uncharted territory for me.

Replying to jeherve:

First pass at a fix: r739334, props tmoorewp

Publicize: remove the permission check from displaying Page accounts that could be used. Also, default Publicize checkboxes on published posts to unchecked so that there is no accidental Publicizing of said post.

comment:12 in reply to: ↑ 11 @jeherve2 years ago

Replying to nogi:

How do I apply the fix? Where can I grab the dependencies from as well as just the new php isn't enough. Sorry for the newbie question, I'm used to Google Code, Trac is uncharted territory for me.

If you're not familiar with Trac or diff files, you can also install the latest Beta version of Jetpack; it includes the fix:

comment:14 @jeherve2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

comment:15 @orionsweb17 months ago

  • Keywords pages added; needs-testing removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

I am now experiencing this same issue as of today on rowntreemontessori.com first our posts were not publicizing to our FB page... research seemed to suggest that deactivating and reactivating the jetpack plugin would remedy the situation...
after doing that we had some issues reconnecting to wordpress.com ... got that looked after and now Facebook shows only my personal account and NOT the FB Page that we wish to link to publicize our posts...

comment:16 @jeherve16 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

@orionsweb Could you update to the most recent version of Jetpack, 2.8. You're running a very old version of the plugin, 2.2.5.

Once your update the problem will disappear.

comment:17 @jandreoni13 months ago

  • Cc jason@… added
  • Resolution fixed deleted
  • Severity changed from critical to blocker
  • Status changed from closed to reopened

Hi, there. Using WP 3.9.1 and Jetpack 3.0.1, and I manage over 100 FB pages. When I am trying to connect a client's blog to their page, which I do indeed manage, I am not seeing the options that are laid out here:

http://jetpack.me/support/publicize/facebook/

Here's what the screen looks like when I click Add New under Facebook:

http://cl.jasonandreoni.com/image/0U241Z2F1x0v

There are NO other options that I can find that will allow me to add to a page I manage.

Please help!

comment:18 @jeherve13 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Here's what the screen looks like when I click Add New under Facebook:
http://cl.jasonandreoni.com/image/0U241Z2F1x0v

@jandreoni I wasn't able to reproduce the issue on my end.

Could you try to deactivate all other plugins on your site, one at a time, just to be sure that the list is not hidden by another plugin?

If that doesn't help, can you please use Jetpack's Debugger module to send us some more information about your site?

  1. Go to the Jetpack page in your dashboard.
  2. Click on the Debug link appearing at the bottom of the page.
  3. Click the link that says "click here to contact Jetpack support."
  4. Fill in the description box and your name and email address.
  5. Click the "Contact Support" button.

Thanks!

Note: See TracTickets for help on using tickets.