WordPress.org

Plugin Directory

jetpack

#1792 closed defect (fixed)

Omnisearch causing a PHP Error

Reported by: markjaquith Owned by: georgestephanis
Priority: normal Severity: normal
Plugin: jetpack Keywords: omnisearch has-patch
Cc: jeremy+wp@…

Description

Error: Declaration of Jetpack_Omnisearch_Comments::pagination() should be compatible with WP_List_Table::pagination($which)

If you extend a class and override a method, the arguments and access levels have to match.

Attachments (1)

1792.diff (746 bytes) - added by markjaquith 10 months ago.

Download all attachments as: .zip

Change History (4)

markjaquith10 months ago

comment:1 markjaquith10 months ago

Untested, but matches the signatures in two instances I found.

comment:2 jeherve10 months ago

  • Cc jeremy+wp@… added
  • Keywords omnisearch has-patch added
  • Owner changed from tmoorewp to georgestephanis

comment:3 georgestephanis10 months ago

  • Resolution set to fixed
  • Status changed from new to closed

In 730887:

Jetpack: Omnisearch: Add parameter to overridden pagination() function. Fixes #1792 props @markjaquith

Note: See TracTickets for help on using tickets.