WordPress.org

Plugin Directory

jetpack

Opened 3 years ago

Closed 2 years ago

#1559 closed defect (fixed)

Jetpack Google+ sharing button issue

Reported by: virendrachandak Owned by: mdawaffe
Priority: normal Severity: normal
Plugin: jetpack Keywords: jetpack
Cc: beaulebens

Description

I found an issue/bug when you have Jetpack (1.5) installed on WordPress (3.4.1) and the Sharing buttons enabled and have the Google+ button on your post. If you have all these enabled, and then go to a post and add "?share=google-plus-1" to the URL, you get a blank white page.

e.g. http://wordpress.org/news/2012/07/event-organizers-unite/?share=google-plus-1

If you try http://wordpress.org/news/2012/07/event-organizers-unite/?share=facebook it take you to facebook share page.

The problem is probably because all other services have a share URL to which we are redirected for sharing. However, there is no url for Google+. So, in file wp-content/plugins/jetpack/modules/sharedaddy/sharing-source.php on lines 928 & 929

		parent::process_request( $post, $post_data );
		die();

So the process_request just processes the request, and there is no redirect and hence we get a blank white page due to the die() on Line 929.

If we see a the same function for other service like "Press This" on line 889 we process the request and then on line 892 we redirect the user.

		// Record stats
		parent::process_request( $post, $post_data );
		
		// Redirect to Press This
		wp_safe_redirect( $url );
		die();

Hence the user is redirected to the service sharing page. In case of google, we don't have any such page and hence it just dies, and therefore we get the blank white page.

Change History (4)

comment:1 @virendrachandak3 years ago

  • Cc virendrachandak added

comment:2 @virendrachandak3 years ago

  • Cc virendrachandak removed

comment:3 @beaulebens3 years ago

  • Cc beaulebens added

How did you end up getting sent to that URL? There shouldn't be anything in the plugin which ever actually directs a user to that URL, since the G+ button uses Google's own code, and thus doesn't go through Jetpack's process_request() handler.

comment:4 @mdawaffe2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [618654]

Note: See TracTickets for help on using tickets.