WordPress.org

Plugin Directory

akismet

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#1511 closed enhancement (fixed)

Improve i18n of Akismet's new widget

Reported by: dimadin Owned by: matt
Priority: normal Severity: normal
Plugin: akismet Keywords: has-patch
Cc:

Description

As reported on Twitter, attached patch improves i18n of a new widget that was broken.

Note that I got error unrelated to above which was fixed for me when I changed to

add_action( 'wp_head', array( $this, 'css' ) );

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'Akismet_New_Widget::css' was given in /wp-includes/plugin.php on line 405

Attachments (1)

akismet_new_widget_i18n.patch (945 bytes) - added by dimadin 2 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 josephscott2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

In [532382]:

Translation improvements for the new widget code, props dimadin

Also mention the new widget code in the change log.

Fixes #1511

comment:2 josephscott2 years ago

I wasn't able to reproduce this the add_action() issue you mentioned. I suspect that this is a difference in PHP versions. I went ahead and committed your version since it worked fine for me as well.

Note: See TracTickets for help on using tickets.