WordPress.org

Plugin Directory

mts-per-post

Opened 13 years ago

Last modified 20 months ago

#122 assigned defect

Cannot See Per-Post Formatting Options

Reported by: jmartin Owned by: chuyskywalker
Priority: normal Severity: major
Plugin: mts-per-post Keywords: php, cgi, dreamhost, text control
Cc:

Description

I just installed Text Control on a WordPress 1.5 blog. The Control Panel shows up on the "Options" page and I can set the site defaults. I've verified that the site defaults actually take effect. However, I cannot see the "Format this post with:" section when writing either Pages or Posts.

Change History (7)

comment:1 @chuyskywalker13 years ago

  • Status changed from new to assigned

The per post option will not show up until the post has been saved once. I was having trouble getting the option to "stick" when writing a blank post, so I took it out for the time being.

Are you able to edit the formatting when editing an existing post?

comment:2 @mahalie13 years ago

I was having the same problem and it turned out to be caused by my server (Dreamhost) which sets 'Run PHP as CGI' for new domains. On my old domain (pre policy-change) Text Control worked swimmingly. I tried switching that domain to 'Run PHP as CGI' and sure enough, Text Control stopped offering the per post settings. I switched it back to regular PHP mode and it started working again.

Maybe there's away to make it work installs running on 'PHP as CGI' since everything else with WordPress seems to work? For now I've switched my domains to run PHP regularly even though my host strongly requests 'as CGI' for security reasons. Maybe this is now a 'feature request' instead of a bug, (except the problem should be noted in the install directions or somethong so people with PHP as CGI can figure out what's wrong).

Hope this helps!

comment:3 @mahalie13 years ago

Oh (p.s, sorry!) I should mention that it was not a matter of the options not showing up on a blank new-post screen. The options weren't showing up at all even on old posts where they used to work.

comment:4 @chuyskywalker13 years ago

Is this still a problem on your blog? I know 1.5 had some issues with several of my plugins that updating to 1.5.1.2 fixes. If you're on the most recent 1.5WP, then let me know -- otherwise update there first and let me know if that fixes anything.

comment:5 @mahalie12 years ago

  • Keywords php cgi dreamhost text control added
  • Severity changed from normal to major

I'm up to 1.5.2 on my blogs now. It seems to be a server config problem that I have no control over. I use Dreamhost and they run PHP as CGI. Still no dice on using Text Control on this blog. I tried switching PHP not to run as CGI and that now breaks my whole WP install, whereas previously it would work - I think they've toggled a lot of options because of security problems.

Anyway, perhaps I'm in a minority too small to worry about, but if you're interested in debugging I'd be happy to help you test.

comment:6 @fireproofsocks6 years ago

In [424302]:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found

comment:7 @githubsync20 months ago

In 1420297:

Error: Failed to load processor CommitTicketReference
No macro or processor named 'CommitTicketReference' found
Note: See TracTickets for help on using tickets.