WordPress.org

Plugin Directory

Changeset 618862


Ignore:
Timestamp:
10/30/12 00:28:37 (18 months ago)
Author:
garyc40
Message:

Add warning for 3.8.9 upgrade.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • wp-e-commerce/branches/branch-3.8/wpsc-admin/admin.php

    r618697 r618862  
    12291229 
    12301230} 
     1231 
     1232function _wpsc_admin_notices_3dot8dot9() { 
     1233    $message = '<p>' . __( 'You are currently using WP e-Commerce 3.8.9. There have been major changes in WP e-Commerce 3.8.9, so backward-compatibility with existing plugins might not always be guaranteed. If you are unsure, please roll back to 3.8.8.5, and set up a test site with 3.8.9 to make sure WP e-Commerce 3.8.9 is compatible with your existing themes and plugins.<br />If you find any incompatibility issues, please <a href="%1$s">report them to us</a> as well as the other plugins or themes\' developers.' , 'wpsc' ) . '</p>'; 
     1234    $message .= "\n<p>" . __( '<a href="%2$s">Hide this warning</a>', 'wpsc' ) . '</p>'; 
     1235    $message = sprintf( 
     1236        $message, 
     1237        'http://getshopped.org/wp-e-commerce-3-8-9-compatibility-issues/', 
     1238        add_query_arg( 'dismiss_389_upgrade_notice', 1 ) 
     1239    ); 
     1240 
     1241    echo '<div id="wpsc-3.8.9-notice" class="error">' . $message . '</div>'; 
     1242} 
     1243 
     1244if ( isset( $_REQUEST['dismiss_389_upgrade_notice'] ) ) 
     1245    update_option( 'wpsc_hide_3.8.9_notices', true ); 
     1246 
     1247if ( ! get_option( 'wpsc_hide_3.8.9_notices' ) ) 
     1248    add_action( 'admin_notices', '_wpsc_admin_notices_3dot8dot9' ); 
Note: See TracChangeset for help on using the changeset viewer.