WordPress.org

Plugin Directory

Changeset 1153786


Ignore:
Timestamp:
05/05/15 13:25:52 (3 years ago)
Author:
SriniG
Message:

v1.7.1: Fix for the upgrade issue reported by some users

Location:
flexi-pages-widget/trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • flexi-pages-widget/trunk/README.md

    r1142957 r1153786  
    1 Flexi Pages Widget 1.7 
    2 ====================== 
     1Flexi Pages Widget 
     2================== 
    33 
    44Flexi Pages Widget is a highly configurable [WordPress](https://wordpress.org/) sidebar widget to list pages and sub-pages. Can be used as an alternative to the default 'Pages' widget. 
  • flexi-pages-widget/trunk/flexi-pages-widget.php

    r1142957 r1153786  
    44 * Plugin URI: http://srinig.com/wordpress/plugins/flexi-pages/ 
    55 * Description: A highly configurable WordPress sidebar widget to list pages and sub-pages. User friendly widget control comes with various options.  
    6  * Version: 1.7 
     6 * Version: 1.7.1 
    77 * Author: Srini G 
    88 * Author URI: http://srinig.com/wordpress 
     
    1212 */ 
    1313 
    14 /*  Copyright 2007-2013 Srini G (email : srinig.com@gmail.com) 
     14/*  Copyright 2007-2015 Srini G (email : srinig.com@gmail.com) 
    1515 
    1616    This program is free software; you can redistribute it and/or modify 
     
    3333include_once( 'inc/class-flexi-pages-widget.php' ); 
    3434 
     35define( 'FLEXIPAGES_VERSION', '1.7.1' ); 
    3536 
    3637function flexipages_init() 
    3738{ 
    3839    if( $old_widget_options = get_option( 'flexipages_widget') ) { 
    39         if( !( $new_widget_options = get_option( 'widget_flexipages') ) ) { 
     40        if( get_option( 'widget_flexipages') ) { 
     41            update_option( 'widget_flexipages', $old_widget_options ); 
     42        } else { 
    4043            add_option( 'widget_flexipages', $old_widget_options ); 
    4144        } 
    4245        delete_option( 'flexipages_widget' ); 
     46    } 
     47 
     48    $plugin_version_stored = get_option( 'flexipages_version' ); 
     49    if( $plugin_version_stored != FLEXIPAGES_VERSION ) { 
     50        add_option( 'flexipages_version', FLEXIPAGES_VERSION ); 
    4351    } 
    4452 
  • flexi-pages-widget/trunk/readme.txt

    r1145358 r1153786  
    44Tags: pages, subpages, menu, hierarchy, sidebar, widget, navigation 
    55Requires at least: 3.0 
    6 Tested up to: 4.2 
     6Tested up to: 4.2.1 
    77Stable tag: trunk 
    88 
     
    198198== Changelog == 
    199199 
     200= v1.7.1 (2015-05-05) = 
     201* Fix to the issue where the options won't upgrade for some users. Thanks to joffs and other users for the inputs. 
     202* Storing the version number in the options table. Could come in handy during future updates. 
     203 
    200204= v1.7 (2015-04-23) = 
    201205* Fixes for errors and warnings 
     
    323327== Upgrade Notice == 
    324328 
    325 = 1.7 = 
    326 Nothing new in terms of features, but many errors and bugs cleaned out, made compatible with latest WP version and best-practices. 
    327  
    328 = 1.6.13 = 
    329 Fixes a little bug introduced in v1.6.12. Upgrade recommended. 
    330  
    331 = 1.6 = 
    332 New feature to display as dropdown added, translation in Catalan and Dutch languages added. Core rewritten. Upgrade recommended. 
     329= 1.7.1 = 
     3301.7 makes use of the WP Widgets API and cleans out many errors and bugs. 1.7.1 comes with a fix for the issue some users were having with upgrade to 1.7. 
Note: See TracChangeset for help on using the changeset viewer.